Remove this ad

Lead

Dec 18 12 9:25 AM

Tags : :

aMule refuse to start if there are part files (aMule created those). If i delete part files it will start first time.

Here is output and backtrace:

rumun@mali:~> gdb amule
GNU gdb (GDB) SUSE (7.4.50.20120603-2.1.2)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-suse-linux".
For bug reporting instructions, please see:
...
Reading symbols from /usr/bin/amule...Reading symbols from /usr/lib/debug/usr/bin/amule.debug...done.
done.
(gdb) run
Starting program: /usr/bin/amule
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Detaching after fork from child process 4571.
2012-12-18 09:18:56: Initialising aMule 2.3.1 compiled with wxGTK2 v2.8.12
2012-12-18 09:18:56: Checking if there is an instance already running...
2012-12-18 09:18:57: No other instances are running.
Detaching after fork from child process 4572.
Detaching after fork from child process 4573.
Detaching after fork from child process 4574.
2012-12-18 09:18:57: ListenSocket: Ok.
[New Thread 0x7fffec267700 (LWP 4575)]
[New Thread 0x7fffeba66700 (LWP 4576)]
[New Thread 0x7fffeb265700 (LWP 4577)]
[New Thread 0x7fffeaa64700 (LWP 4578)]
[New Thread 0x7fffea263700 (LWP 4579)]
[New Thread 0x7fffe9a62700 (LWP 4580)]
[New Thread 0x7fffe9261700 (LWP 4581)]
[New Thread 0x7fffe8a60700 (LWP 4582)]
[New Thread 0x7fffe3fff700 (LWP 4583)]
Detaching after fork from child process 4584.
[New Thread 0x7fffe25ff700 (LWP 4585)]
[New Thread 0x7fffe1dfe700 (LWP 4586)]
[Thread 0x7fffe1dfe700 (LWP 4586) exited]
2012-12-18 09:19:00: Loading temp files from /home/rumun/.aMule/Temp.
2012-12-18 09:19:00: Loading PartFile 1 of 197

Program received signal SIGSEGV, Segmentation fault.
ECNotifier:ownloadFile_SetDirty (this=0x6100000064, file=0x1184800) at ExternalConn.cpp:2138
2138 for(std::map::iterator i = m_msg_source.begin();
Missing separate debuginfos, use: zypper install dbus-1-glib-debuginfo-0.98-6.1.2.x86_64 fontconfig-debuginfo-2.9.0-3.9.1.x86_64 gconf2-debuginfo-3.2.5-2.1.2.x86_64 glibc-debuginfo-2.15-22.9.1.x86_64 glibc-locale-debuginfo-2.15-22.9.1.x86_64 gnome-vfs2-debuginfo-2.24.4-10.2.1.x86_64 gtk2-engine-clearlooks-debuginfo-2.20.2-11.1.2.x86_64 gvfs-debuginfo-1.12.3-3.2.2.x86_64 libGeoIP1-debuginfo-1.4.8-3.1.2.x86_64 libICE6-debuginfo-1.0.8-2.1.2.x86_64 libSM6-debuginfo-1.2.1-2.1.2.x86_64 libX11-6-debuginfo-1.5.0-2.1.2.x86_64 libXau6-debuginfo-1.0.7-2.1.2.x86_64 libXcomposite1-debuginfo-0.4.3-2.1.2.x86_64 libXcursor1-debuginfo-1.1.13-2.1.2.x86_64 libXdamage1-debuginfo-1.1.3-2.1.2.x86_64 libXext6-debuginfo-1.3.1-2.1.2.x86_64 libXfixes3-debuginfo-5.0-2.1.2.x86_64 libXi6-debuginfo-1.6.1-2.1.2.x86_64 libXinerama1-debuginfo-1.1.2-2.1.2.x86_64 libXrandr2-debuginfo-1.3.2-2.1.2.x86_64 libXrender1-debuginfo-0.9.7-2.1.2.x86_64 libXxf86vm1-debuginfo-1.1.2-2.1.2.x86_64 libatk-1_0-0-debuginfo-2.4.0-2.1.2.x86_64 libavahi-client3-debuginfo-0.6.31-3.6.1.x86_64 libavahi-common3-debuginfo-0.6.31-3.6.1.x86_64 libavahi-glib1-debuginfo-0.6.31-3.3.1.x86_64 libbluray1-debuginfo-0.2.2-2.1.2.x86_64 libcairo2-debuginfo-1.12.2-2.1.2.x86_64 libcryptopp-5_6_1-0-debuginfo-5.6.1-15.1.8.x86_64 libdbus-1-3-debuginfo-1.5.12-4.10.1.x86_64 libexpat1-debuginfo-2.1.0-2.1.3.x86_64 libffi47-debuginfo-4.7.1_20120723-1.1.1.x86_64 libfreetype6-debuginfo-2.4.9-4.1.2.x86_64 libgcc47-debuginfo-4.7.1_20120723-1.1.1.x86_64 libgdk_pixbuf-2_0-0-debuginfo-2.26.1-2.1.4.x86_64 libgio-2_0-0-debuginfo-2.32.4-4.8.1.x86_64 libglib-2_0-0-debuginfo-2.32.4-4.8.1.x86_64 libgmodule-2_0-0-debuginfo-2.32.4-4.8.1.x86_64 libgobject-2_0-0-debuginfo-2.32.4-4.8.1.x86_64 libgtk-2_0-0-debuginfo-2.24.10-3.1.2.x86_64 libgvfscommon0-debuginfo-1.12.3-3.2.2.x86_64 libjpeg62-debuginfo-62.0.0-15.5.1.x86_64 liblzma5-debuginfo-5.0.3-12.2.2.x86_64 libopenssl1_0_0-debuginfo-1.0.1c-2.4.1.x86_64 libpango-1_0-0-debuginfo-1.30.1-1.1.2.x86_64 libpcre1-debuginfo-8.30-3.1.2.x86_64 libpixman-1-0-debuginfo-0.24.4-4.1.2.x86_64 libpng14-14-debuginfo-1.4.11-2.5.1.x86_64 libselinux1-debuginfo-2.0.91-19.1.15.x86_64 libstdc++47-debuginfo-4.7.1_20120723-1.1.1.x86_64 libtiff5-debuginfo-4.0.2-1.9.1.x86_64 libudev0-debuginfo-182-4.25.1.x86_64 libupnp6-debuginfo-1.6.13-6.1.2.x86_64 libuuid1-debuginfo-2.21.2-4.5.1.x86_64 libwx_baseu-2_8-0-wxcontainer-debuginfo-2.8.12-13.1.2.x86_64 libwx_baseu_net-2_8-0-wxcontainer-debuginfo-2.8.12-13.1.2.x86_64 libwx_gtk2u_adv-2_8-0-wxcontainer-debuginfo-2.8.12-13.1.2.x86_64 libwx_gtk2u_core-2_8-0-wxcontainer-debuginfo-2.8.12-13.1.2.x86_64 libxcb-render0-debuginfo-1.8.1-2.4.1.x86_64 libxcb-shm0-debuginfo-1.8.1-2.4.1.x86_64 libxcb1-debuginfo-1.8.1-2.4.1.x86_64 libxml2-2-debuginfo-2.7.8+git20120223-8.9.1.x86_64 nss-mdns-debuginfo-0.10-55.5.1.x86_64 zlib-debuginfo-1.2.7-2.1.2.x86_64

(gdb) bt

#0 ECNotifier:ownloadFile_SetDirty (this=0x6100000064, file=0x1184800) at ExternalConn.cpp:2138
#1 0x0000000000567b91 in MuleNotify:ownloadCtrlUpdateItem (item=0x1184800) at GuiEvents.cpp:127
#2 0x000000000056799b in MuleNotify::HandleNotification (ntf=...) at GuiEvents.cpp:75
#3 0x000000000056fe50 in DoNotify (arg1=0x1184800, func=) at GuiEvents.h:397
#4 CPartFile::UpdateDisplayedInfo (this=0x1184800, force=true) at PartFile.cpp:3618
#5 0x000000000057b45c in CPartFile::LoadPartFile (this=0x1184800, in_directory=..., filename=..., from_backup=, getsizeonly=false)
at PartFile.cpp:409
#6 0x000000000049ccac in CDownloadQueue::LoadMetFiles (this=0xc97990, path=...) at DownloadQueue.cpp:135
#7 0x000000000046bf5f in CamuleApp::OnInit (this=0xa4a3c0) at amule.cpp:561
#8 0x0000000000509329 in CamuleGuiApp::OnInit (this=0xa4a3c0) at amule-gui.cpp:287
#9 0x00007ffff6275664 in wxEntry(int&, wchar_t**) () from /usr/lib64/wx-2.8-wxcontainer/libwx_baseu-2.8.so.0
#10 0x0000000000450592 in main (argc=1, argv=) at amule-gui.cpp:93
Quote    Reply   
Remove this ad
Remove this ad

#1 [url]

Dec 20 12 3:13 PM

Re: amule won't when there are existing part files opensuse

Did you compile aMule yourself or installed it from a package?
What triggered the problem - an update ?

Quote    Reply   

#2 [url]

Dec 20 12 5:29 PM

Re: amule won't when there are existing part files opensuse

Firstly installed from package. Then, compiled my self latest aMule and wx dev from packages.
I'm not sure if it is related to update as i don't remember.
But, let me say again: without part files emule works.

Quote    Reply   

#3 [url]

Dec 20 12 6:11 PM

Re: amule won't when there are existing part files opensuse

I can assure you - it works with partfiles too. Usually.
Move half of your partfiles away. If it still crashes, move them back and the other half away and so on.
I suspect there is something broken with one of them in an interesting way.

Quote    Reply   

#4 [url]

Dec 20 12 6:18 PM

Re: amule won't when there are existing part files opensuse

I have tested again. It works only without part files.
Every part file from my list will crash it when moved to Temp folder.
So i tried this also:
Empty folder (no part and other files). Emule started. As soon as i add new downlaod from search it crashes.

Quote    Reply   
Remove this ad

#5 [url]

Dec 20 12 6:41 PM

Re: amule won't when there are existing part files opensuse

Issue was solved. Some of amule files from toplevel directory were corrupted somehow. Deleting those solved problem.

Thank you for your time

Quote    Reply   

#6 [url]

Dec 20 12 9:04 PM

Re: amule won't when there are existing part files opensuse

Which files precisely were corrupted? You do not happen to have a copy of them so I could try to reproduce the problem?

Quote    Reply   

#7 [url]

Dec 20 12 9:35 PM

Re: amule won't when there are existing part files opensuse

Unfortunately not as i forgot to save a copy. But method SetDirty is causing this I believe so it might be good starting point to locate a file.
If this issue repeat, I'll save fa copy of files.

Quote    Reply   
Remove this ad
Add Reply

Quick Reply

bbcode help