Remove this ad

Lead

Aug 21 13 3:31 PM

Tags : :

Configured aMule SVN (rev. 10806) for 'x86_64-unknown-linux-gnu'.

aMule enabled options:

**** aMule Core ****
Prefix where aMule should be installed? /usr
Should aMule be compiled with i18n support? yes
Should aMule be compiled in debug mode? no
Should aMule be compiled with profiling? no
Should aMule be compiled with optimizations? yes
Should aMule be compiled with UPnP support? yes
Should aMule be compiled with IP2country support? yes
Should aMule monolithic application be built? no
Should aMule daemon version be built? yes
Should aMule remote gui be built? no
Crypto++ library/headers style? installed

**** aMule TextClient ****
Should aMule Command Line Client be built? yes

**** aMule WebServer ****
Should aMule WebServer be built? yes

**** aMule ED2K Links Handler ****
Should aMule ED2K Links Handler be built? yes

**** aMuleLinkCreator ****
Should aMuleLinkCreator GUI version (alc) be built? no
Should aMuleLinkCreator for console (alcc) be built? yes

**** aMule Statistics ****
Should C aMule Statistics (CAS) be built? no
Should aMule GUI Statistics (wxCas) be built? no
Should xas XChat2 plugin be installed? no
Should plasmaMule plasma-applet be build? no

**** General Libraries and Tools ****
Should ccache support be enabled? yes
Libraries aMule will use to build:
wxWidgets 2.9.5 (gtk2,shared)
crypto++ 5.6.2 (installed, in /usr)
libupnp 1.6.18
libintl system
libpng 1.6.3
zlib 1.2.8



build log:

http://sl1pkn07.no-ip.com/paste/view/8e3e8c58

greetings
Quote    Reply   
Remove this ad
Remove this ad

#1 [url]

Aug 21 13 7:27 PM

Re: fail build with wxGTK 2.9.5

Ah, they have brought out another release. I'll check it out some day.
Mind, wx 2.8.12 is still our official platform, and 2.9 is still tagged as experimental.
That said - this looks like a build error to me. Check out a fresh source and rebuild from scratch, and tell me if that helped.

Quote    Reply   

#2 [url]

Aug 25 13 5:33 PM

Re: fail build with wxGTK 2.9.5

I can confirm this. That's what you get from including internal headers and using internal classes. We are using an undocumented class wxExecuteData which apparently was dropped from wx.

Quote    Reply   

#3 [url]

Aug 25 13 7:13 PM

Re: fail build with wxGTK 2.9.5

Fixed in 10807. Had to jettison some functionality in amuled (prevent zombie child processes) of which I have no idea if it was useful at all. amuled still works fine.

Quote    Reply   
Remove this ad

#6 [url]

Sep 30 13 9:38 PM

Re: fail build with wxGTK 2.9.5

thanks for quick fix

greetings

Quote    Reply   
Remove this ad
Add Reply

Quick Reply

bbcode help