Remove this ad

Lead

Nov 6 13 9:51 PM

Tags : :

y reboot my mac, erase cache cookies etc and deleted AMULE and download it again several times and the same log appears..

can you help me?
thanks

the next error appears on a window

------
Process: amule [1273]
Path: /Users/USER/Downloads/aMule.app/Contents/MacOS/amule
Identifier: org.amule.aMule
Version: 2.3.1 (2.3.1)
Code Type: X86 (Native)
Parent Process: launchd [171]
Responsible: amule [1273]
User ID: 501

Date/Time: 2013-11-06 11:00:14.015 -0600
OS Version: Mac OS X 10.9 (13A603)
Report Version: 11
Anonymous UUID: 92E2A6ED-29F4-802E-4420-72B3F457188F

Sleep/Wake UUID: DED66FF9-E537-49A0-8454-BC98B3568813

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x9bfea952 __pthread_kill + 10
1 libsystem_pthread.dylib 0x974b4167 pthread_kill + 101
2 libsystem_c.dylib 0x93580340 abort + 155
3 org.amule.aMule 0x00277033 OnUnhandledException() + 815
4 org.amule.aMule 0x0000ef53 CamuleApp::OnUnhandledException() + 141
5 org.amule.aMule 0x005d61a1 wxEntry(int&, wchar_t**) + 233
6 org.amule.aMule 0x005d622a wxEntry(int&, char**) + 56
7 org.amule.aMule 0x001632fc main + 24
8 org.amule.aMule 0x00002a12 _start + 216
9 org.amule.aMule 0x00002939 start + 41

Thread 1:
0 libsystem_kernel.dylib 0x9bfeb046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x974b4dcf _pthread_wqthread + 372
2 libsystem_pthread.dylib 0x974b8cce start_wqthread + 30

Thread 2:: Dispatch queue: com.apple.libdispatch-manager
0 libsystem_kernel.dylib 0x9bfeb992 kevent64 + 10
1 libdispatch.dylib 0x978838bd _dispatch_mgr_invoke + 238
2 libdispatch.dylib 0x97883556 _dispatch_mgr_thread + 52

Thread 3:
0 libsystem_kernel.dylib 0x9bfeb046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x974b4dcf _pthread_wqthread + 372
2 libsystem_pthread.dylib 0x974b8cce start_wqthread + 30

Thread 4:
0 libsystem_kernel.dylib 0x9bfeb046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x974b4dcf _pthread_wqthread + 372
2 libsystem_pthread.dylib 0x974b8cce start_wqthread + 30

Thread 5:

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x00000000 ebx: 0x00276d11 ecx: 0xbffffb9c edx: 0x9bfea952
edi: 0xa0b931a8 esi: 0x00000006 ebp: 0xbffffbb8 esp: 0xbffffb9c
ss: 0x00000023 efl: 0x00000206 eip: 0x9bfea952 cs: 0x0000000b
ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
cr2: 0x01b57000

Logical CPU: 0
Error Code: 0x00080148
Trap Number: 132
Quote    Reply   
Remove this ad
Remove this ad

#1 [url]

Nov 7 13 12:36 AM

Re: amule crashes i've tried to reinstall it but it fails

Maybe something corrupted in aMule settings folder? (Statistics?)
Try to rename

~/Library/Application Support/aMule

as

~/Library/Application Support/aMule.previous

and then restart aMule: aMule will re-create the folder (using default settings)

I suggest to rename (and NOT to delete) so you can still recover files if needed.

Bye,
Mr Hyde

Quote    Reply   

#2 [url]

Nov 7 13 4:32 PM

Re: amule crashes i've tried to reinstall it but it fails

thanks i´ve tried that before posting but theres no a mule folder on Library! i deleted the amule from my mac and now i can't install it... so theres no amule folder anywhere (only amule downloads )

Quote    Reply   

#3 [url]

Nov 7 13 8:18 PM

Re: amule crashes i've tried to reinstall it but it fails

Just to avoid confusion:
I wrote "~/Library" and NOT "/Library".

as probably you already knows the character "~" has a special meaning in Unix-like environments: it refers to user's home directory.

So, just to write the full path (with the user home expanded) you must look for
[code]
/Users/REPLACETHISWITHYOURUSERNAME/Library/Application Support/aMule
[/code]

Remember also that, starting from Lion, the folder
[code]
~/Library
[/code]
or, with the home expanded
[code]
/Users/REPLACETHISWITHYOURUSERNAME/Library
[/code]
is hidden by default.

In Internet you can find a lot of pages describing how to access that folder (just one example: http://helpx.adobe.com/x-productkb/glob ... files.html)

Another thing: aMule (like many other MacOS applications) does not require "installation" on MacOS, you can simply explode the containing zip/mount the containing .dmg file and then click on aMule application to start it.
Just for convenience it is usually copied in Application folder.

And about shared files and downloaded file: in MacOS, by default, the folder containing downloaded file is
[code]
/Users/REPLACETHISWITHYOURUSERNAME/Documents/aMule Downloads
[/code]
while the "Temp" folder is
[code]
/Users/REPLACETHISWITHYOURUSERNAME/Library/Application Support/aMule/Temp
[/code]

(at least these are currently the default folder used by my aMule on my MacMini )

All this folders (folder for settings and Temp in hidden ~/Library and folder for Downloads) are created by aMule the first time (if needed).

I beg your pardon if I just reported already well known concepts .

Bye,
Mr Hyde

Quote    Reply   
Remove this ad

#4 [url]

Nov 7 13 11:18 PM

Re: amule crashes i've tried to reinstall it but it fails

Crash is in wxWidgets startup code. That is before aMule has started doing anything, like reading any config data. So it can't be that.
Some MacOS incompatibility? I recently tried to run an executable built with MSVC2013 on an XP machine which said "not a win32 application" (it was one, but one that required win7). Something like that?

Quote    Reply   

#5 [url]

Nov 8 13 2:36 PM

Re: amule crashes i've tried to reinstall it but it fails

Ok, my fault: I just noticed that we are in "Compilation problems" area.

@Stu: as regards changes in MacOS: yes, in my attempts to build for 64 bits with new wxWidgets I noticed a couple of things.
As you probably remember, on start my concerns were about some upgrade in my MaPorts development system, but now I believe that the problems are caused by a mix n new XCode and wxWidgets code.

One thing I noticed: amule crashes on start (and the crash is really similar o the crash reported in this thread) an probably this crash is caused by a function called too early (I'm speaking about "setFNConv" in Path.cpp: commenting-out this function or delayng the call seems to avoid the crash, if I remember correctly).

But, till now, I was thinking that this problem was related to current SVN version and wxWidgets <= 2.9.x , not aMule 2.3.1 and wx 2.8.x (anyway I never tried to rebuid aMule 2.3.1..., at least I didn't rebuild it recently).

Last time I've built aMule 2.3.1 for Mac, with success, I used:
- wxWidgets 2.8.12 (with CARBON enabled)
- macports
- MacOS 10.6.x SnowLeopard
- Xcode 3.X
- SDK 10.4 (I built it for PPC and i386 architectures)

Current SVN version on MacOS with wx 2.9.x and 2.3.x (COCOA) has other issues, but I guess depending on wx instability on MacOS: after the "fix" of the crash, there is a strange "slow-down", or at least there was till some version of wx ago (3.0 branch).

To come back to the original problem, If we are speaking about 2.3.1 and wxWidgets 2.8.12 (CARBON) I can try to rebuild aMule, on SnowLepard with "old" XCode version.
I had some problem with current XCode version and wxWidgets 2.8.12 (this is the reason for which, on Mavericks, I'm trying to build with wxWidgets 2..x).

Anyway, during my free time, I will continue to investigate about the issues of aMule SVN built against wx 3.0/Cocoa (even if I'm not so expert MacOS environment ...)

Bye,
Mr Hyde

Quote    Reply   

#6 [url]

Nov 9 13 5:35 PM

Re: amule crashes i've tried to reinstall it but it fails

I wouldn't touch wx 2.9 anymore. Please test build and function with wx 3.0 rc2.

Regarding setFNConv: it should only be called if wxUSE_GUI is 0, which is when wx is built as wxbase only. So it shouldn't trigger on Mac. Still I'm finding this highly dubious and am tempted to just throw it out.

Quote    Reply   
Remove this ad
Add Reply

Quick Reply

bbcode help