Remove this ad

Lead

Jan 7 14 6:34 AM

Tags : :

the log: http://sl1pkn07.no-ip.com/paste/view/c02565ef

greetings
Quote    Reply   
Remove this ad
Remove this ad

#4 [url]

Jan 10 14 9:43 PM

Re: fail build if wxgtk is build with --enable-stl

Some problem with your flex I guess.
Try to restore the original Scanner.cpp and touch it or remove Scanner.l .

Quote    Reply   
Remove this ad

#5 [url]

Jan 10 14 10:30 PM

Re: fail build if wxgtk is build with --enable-stl

back to tar.bz2, and build without copy sources to anhoter instance* works

from svn, build by archlinux package maker, fail

archlinux package maker download sources from svn and then copy these sources to another instance to build (copy is a internal process)
if use tar.bz2 can modif this behaviour. see related*

*related: post20375284.html#p20375284

greetings

Quote    Reply   

#6 [url]

Jan 11 14 6:58 PM

Re: fail build if wxgtk is build with --enable-stl

If you check out SVN with the option "keep original time stamps" the .cpp is newer than the .l , so the flex is skipped and it works.
If you check out with "set all timestamps to now", or copy with a copy tool that touches time stamps, the .l can end up newer than the .cpp, flex is called and produces something that doesn't compile.
The root of the problem is the bad Flex of course.

Quote    Reply   

#7 [url]

Feb 14 14 3:25 PM

Re: fail build if wxgtk is build with --enable-stl

no is flex problem... is "my" problem :S

if copy sources with "cp -Rp" to preserve timestamps (like you say) build OK (if use sources package)

sorry for all :S

Quote    Reply   
Remove this ad
Add Reply

Quick Reply

bbcode help